Error during installation, blank screen.

Important things to be careful of in case you get blank screen, or any errors:

1. Make sure System Requirements are met by your server. 

2. Make sure the these three .htaccess files are there after upload:

  • grassblade-lrs/.htaccess
  • grassblade-lrs/app/.htaccess
  • grassblade-lrs/app/webroot/.htaccess

3. Its recommended to name the folder as "grassblade-lrs". If you are not using the default /grassblade-lrs/ folder, or its in another path. You would need to check the .htaccess files and make sure the RewriteBase path is correctly adjusted in the .htaccess files.

4. Make sure that the following folders are there in /grassblade-lrs/ folder:

  • app/tmp
  • app/tmp/logs
  • app/tmp/cache
  • app/tmp/cache/persistant
  • app/tmp/cache/models

All these folders MUST have 777 file permissions.  

5.  If step 4 above did not solve the problem, delete all the files inside these folders, but do not delete the folder itself: 

  • app/tmp/cache/persistant
  • app/tmp/cache/models

6. Confirm with your host that Caching is disabled for everything in /grassblade-lrs/ folder. If you are using WPEngine, or similar host. You will definitely need to ask them.  

7. If you face any issue, looking at the log files in the logs folder /app/tmp/logs/ might help.

8. You can try changing the following line in /app/Config/core.php

Configure::write('debug', 0);

to

Configure::write('debug', 2); 

This will enable debug mode, and show more descriptive errors. Make sure you revert back when you are done. 

 

 

You can also order for our GrassBlade LRS Installation Service and have us install it for you. 

 

 

Home | GrassBlade xAPI Companion | GrassBlade LRS

 

Have more questions? Submit a request

3 Comments

  • 0
    Avatar
    Sanne Dideriksen

    I've uploaded the zip - but I'm getting '/grassblade-lrs/Configure/Database not found'. there was a htacess.txt file in the root folder of grassblade-lrs - I renamed it to .htacess - new error '/app/webroot/Configure/Database not found'. Otherwise I only have .htaccess files here: /grassblade-lrs/lib/Cake/Console/Templates/skel/webroot/.htaccess and /grassblade-
    lrs/lib/Cake/Console/Templates/skel/.htaccess

    ... what is right, what is wrong?!

  • 0
    Avatar
    Pankaj Agrawal

    Sanne,

    .htaccess files is in all three places:
    grassblade-lrs/.htaccess
    grassblade-lrs/app/.htaccess
    grassblade-lrs/app/webroot/.htaccess

    If you don't have it on your server, you can get it from your zip file. If you don't see it, you might need to enable viewing hidden files in your explorer.

    If you are still not able to get it solved, please create a support ticket.

  • 0
    Avatar
    Sanne Dideriksen

    Of course! I extracted the zip before I uploaded it and then forgot to check the zip! Thankyou - it's working :)

Please sign in to leave a comment.
Powered by Zendesk